Table of Contents

Information

TODOs

Download

FreeBSD-14.1-RELEASE-amd64-memstick.img

Installation Notes

Partitioning

ZFS

System Configuration

System Hardening

User

Network

Network

Wireless

su -l
ee /etc/wpa_supplicant.conf
network={
 ssid="myssid" 
 psk="mypsk" 
}

USB Tethering

su -l
sysrc ifconfig_ue0=SYNCDHCP
/etc/netstart

Update

FreeBSD

su -l
freebsd-update fetch install
sync && reboot

pkg

su -l
pkg update --force
pkg upgrade

Xorg

su -l
pkg install xorg drm-kmod
pw groupmod video -m espionage724
sysrc kld_list+=i915kms

Xfce

su -l
pkg install xfce
ee /etc/fstab
# Xfce
proc /proc procfs rw 0 0
sysrc dbus_enable="YES"
echo '. /usr/local/etc/xdg/xfce4/xinitrc' > /home/espionage724/.xinitrc
chown espionage724:espionage724 /home/espionage724/.xinitrc
sync && reboot

Login

startx

Software

Initial

su -l
pkg install filezilla firefox xdg-user-dirs

XDG Dirs

exit
xdg-user-dirs-update --force

General

su -l
pkg install evince-lite evolution foliate gbrainy gimp keepassxc libreoffice mate-calc mpv thunar-archive-plugin transmission-gtk xfce4-screensaver xfce4-screenshooter-plugin xfce4-whiskermenu-plugin android-tools aria2 cups en-freebsd-doc en-hunspell gnome-keyring gstreamer1-plugins-good gstreamer1-plugins-ugly gstreamer1-libav gtk-sharp30 htop icoutils libressl mesa-demos noto unar wget xarchiver xrandr yt-dlp 

Wine

wine wine-gecko wine-mono winetricks

Intel

libva-intel-driver

Games

neverball xonotic

DevilutionX

devilutionx

Doomsday Engine

doomsday fluid-soundfont

FlightGear

flightgear flightgear-data

Other

minecraft-client

Tor Browser

tor-browser

Settings

Groups

su -l
pw groupmod 'operator' -m 'espionage724'

32-bit Wine

'/usr/local/share/wine/pkg32.sh' install wine mesa-dri gstreamer1-plugins-good gstreamer1-plugins-ugly gstreamer1-libav libressl
'/usr/local/share/wine/pkg32.sh' update --force
'/usr/local/share/wine/pkg32.sh' upgrade

Xfce

Appearance

Panel Preferences

Terminal

Window Manager

loader.conf

Spinesnap

su -l
ee '/boot/loader.conf'
autoboot_delay="2"
hw.usb.usbhid.enable="1"

Unused

hw.acpi.osname="Windows 2017"
exec="gop set 0"

Boot Commands

boot
gop list

rc.conf

Spinesnap

su -l
ee '/etc/rc.conf'
clear_tmp_enable="YES"
syslogd_flags="-ss"
hostname="Spinesnap"
ifconfig_em0="inet 192.168.1.150 netmask 255.255.255.0"
defaultrouter="192.168.1.1"
ifconfig_em0_ipv6="inet6 accept_rtadv"
local_unbound_enable="YES"
ntpd_enable="YES"
ntpd_sync_on_start="YES"
moused_nondefault_enable="NO"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="NO"
zfs_enable="YES"
kld_list="i915kms"
dbus_enable="YES"
cupsd_enable="YES"

sysctl.conf

Spinesnap

su -l
ee '/etc/sysctl.conf'
dev.hwpstate_intel.0.epp=0

device.hints

Spinesnap

su -l
ee '/boot/device.hints'
hint.hdac.0.cad0.nid20.config="as=1 seq=0"
hint.hdac.0.cad0.nid33.config="as=1 seq=15 device=Headphones"

Keyboard Shortcuts

bash -c "secret-tool lookup 'keepass' 'default' | keepassxc --pw-stdin ~/'Documents/keepass.kdbx'"
xfce4-terminal --title='FreeBSD Updater' --command "su -l 'root' -c 'freebsd-update fetch install && pkg update --force && pkg upgrade && sync && echo 'Done' && sleep '3''"
xfce4-popup-whiskermenu
mixer 'vol'='+5%' >> /dev/null 2>&1
mixer 'vol'='-5%' >> /dev/null 2>&1
mixer 'vol'='mute=toggle' >> /dev/null 2>&1

Keys

Network

local-unbound DNS

cat '/etc/rc.conf' | grep 'local_unbound_enable'
su -l
ee '/etc/resolv.conf'
nameserver 127.0.0.1
options edns0

Printer

CUPS

su -l
sysrc cupsd_enable="YES"
service 'cupsd' start

Printer

ipp://192.168.1.164/ipp/print
Kole

Game Controllers

profile.d

Mesa

su -l
ee '/usr/local/etc/profile.d/Mesa-tweaks.sh'
# Mesa
export MESA_DISK_CACHE_SINGLE_FILE='1'
export MESA_DISK_CACHE_DATABASE='1'
export MESA_DISK_CACHE_COMBINE_RW_WITH_RO_FOZ='1'
export VAAPI_MPEG4_ENABLED='1'
export mesa_glthread='true'
export MESA_NO_ERROR='1'

# End

OpenJDK

su -l
ee '/etc/fstab'
# OpenJDK
fdesc /dev/fd fdescfs rw 0 0
mount | grep 'fdesc'

KeePassXC

Settings

Add Database Password to GNOME Keyring

secret-tool store --label='KeePass' 'keepass' 'default'

Secure Shell

Drive Maintenance

UFS

su -l
fsck_ufs -E -f -y -z '/dev/nda0p2'

Wine

Xorg

Full RGB HDMI

ee ~/'.xinitrc'
xrandr --output HDMI-1 --set "Broadcast RGB" Full
xrandr --output HDMI-1 --set "content type" Game

Firefox

Notable Folders and Commands

Font Cache

fc-cache -r -v

Drive Wipe

gpart show
gpart destroy -F 'da0'

USB Flash Drive

camcontrol devlist
usbconfig -d '/dev/ugen0.6' power_off

User/Group

awk -F":" '{print $1}' /etc/passwd
awk -F":" '{print $1}' /etc/group
pw userdel 'x' -r
pw groupdel 'x'

pkg

pkg info -l x
pkg autoremove

Handbook

pkg info -l 'en-freebsd-doc'
gio open '/usr/local/share/doc/freebsd/en/books/handbook'

CPU Frequency

su -l root -c "sysctl 'dev.cpu.0.freq' 'dev.cpu.1.freq' 'dev.cpu.2.freq' 'dev.cpu.3.freq' 'dev.cpu.4.freq' 'dev.cpu.5.freq' 'dev.cpu.6.freq' 'dev.cpu.7.freq'"

Network Restart

su -l
'/etc/netstart'

hw-probe

su -l
pkg install 'hw-probe'
hw-probe -all -upload

Crashdump Clean-up

rm -fv ~/*'.core'

Xfce Settings Reset

rm -fv ~/'.config/xfce4/xfconf/xfce-perchannel-xml/displays.xml'
gio open ~/'.config/xfce4/xfconf/xfce-perchannel-xml'
gio open ~/'.config/xfce4/xfconf'

Audio Output Switch

mixer -a
echo ' Headphones ' && mixer -d 'pcm1' -f '/dev/mixer1'
echo ' Onboard ' && mixer -d 'pcm0' -f '/dev/mixer0'

Logs

newsyslog -v -CC -N
cat '/dev/null' > '/var/log/all.log'
cat '/dev/null' > '/var/log/Xorg.0.log'
gio open '/var/log'
ls -la '/var/log'

syslog.conf

all.log

Enable
su -l
ee '/etc/syslog.conf'
#*.*                                            /var/log/all.log
Permissions
su -l
touch '/var/log/all.log' && chmod '600' '/var/log/all.log'
View
su -l
ee '/var/log/all.log'

Other Files/Paths

5)
dvd1: Additionally, this can be written to a USB memory stick (flash drive) for the amd64 architecture and used to do an install on machines capable of booting off USB drives.
7)
2024/09/08: Intel Wireless-AC 9560: 30MB/s from NAS with wifibox, 2MB/s native, 15MB/s USB Tether
8)
pkg32.sh has echo “Don't run this script as root!”
9)
default app menu doesn't allow right-clicking desktop entries which prevents extra 2004scape and Wine launcher stuff
10)
when set from a USB keyboard, requires hw.usb.usbhid.enable=1
11)
presumably double-sided printing, flip-on-long-edge