Table of Contents

Information

Installation Notes

SSD Wipe

sudo blkdiscard --verbose '/dev/sda'
systemctl suspend
sudo rm -f '/sys/firmware/efi/efivars/'* && sudo blkdiscard --verbose '/dev/sda' && sudo hdparm --user-master u --security-set-pass 'x' '/dev/sda' && sudo hdparm --user-master u --security-erase 'x' '/dev/sda' && sudo hdparm --user-master u --security-set-pass 'x' '/dev/sda' && sudo hdparm --user-master u --security-erase-enhanced 'x' '/dev/sda' && sync

Notes

Download

Copy to USB

sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/Install\ macOS\ Catalina

HOSTS

sudo curl 'https://raw.githubusercontent.com/StevenBlack/hosts/master/alternates/fakenews-gambling/hosts' -o '/private/etc/hosts' && sync && sudo dscacheutil -flushcache;sudo killall -HUP mDNSResponder
cat '/private/etc/hosts' | grep 'Date:'
sudo nano '/private/etc/hosts'

Programs

purge-wrangler

curl 'https://raw.githubusercontent.com/mayankk2308/purge-wrangler/master/purge-wrangler.sh' -o ~/'Downloads/purge-wrangler.sh' && sync && cd ~/'Downloads' && bash 'purge-wrangler.sh'

Audacity

FFmpeg

Corsair

ckb-next

Auto-start Fix

sudo curl 'https://raw.githubusercontent.com/ckb-next/ckb-next/master/macos/org.ckb-next.plist' -o '/Library/LaunchAgents/org.ckb-next.plist' && sync

iCUE

FileZilla

GIMP

KeePassXC

Keybase

Mozilla Firefox

Notes

Remove Features

rm -Rfv '/Applications/Firefox.app/Contents/Resources/browser/features'

Settings

Default Profile

rm -fv '/tmp/profiles.ini' && nano '/tmp/profiles.ini'
[General]
StartWithLastProfile=1

[Profile0]
Name=default
IsRelative=1
Path=Profiles/espionage724
Default=1

user.js

rm -fv '/tmp/user.js' && nano '/tmp/user.js'
/***********
 * General *
 ***********/

user_pref("extensions.screenshots.disabled", true);
user_pref("reader.parse-on-load.enabled", false);

user_pref("media.mediasource.experimental.enabled", true);
user_pref("media.mediasource.ignore_codecs", true);
user_pref("media.autoplay.enabled", false);

user_pref("webgl.disabled", true);
user_pref("webgl.enable-webgl2", false);
user_pref("accessibility.force_disabled", 1);
user_pref("mousewheel.min_line_scroll_amount", 40);
user_pref("browser.tabs.drawInTitlebar", true);

/*******
 * U2F *
 *******/

user_pref("security.webauth.u2f", true);

/*******
 * END *
 *******/
VPN
/***********
 * Privacy *
 ***********/

user_pref("network.dns.disableIPv6", true);
user_pref("media.peerconnection.enabled", false);

Apply Settings

ls '/tmp/profiles.ini' '/tmp/user.js' && pkill 'firefox' && rm -Rfv ~/'Library/Application Support/Firefox' && sync && mkdir -p ~/'Library/Application Support/Firefox/Profiles/'$USER && mv '/tmp/profiles.ini' ~/'Library/Application Support/Firefox/profiles.ini' && mv '/tmp/user.js' ~/'Library/Application Support/Firefox/Profiles/'$USER'/user.js' && sync && cat ~/'Library/Application Support/Firefox/profiles.ini' | grep $USER && cat ~/'Library/Application Support/Firefox/Profiles/'$USER'/user.js' | grep 'Custom Stuff' && sleep '1' && sync || '/Applications/Firefox.app/Contents/MacOS/firefox' -p 'default'

Extensions

Download

open 'https://addons.mozilla.org/en-US/firefox/addon/decentraleyes/versions' && open 'https://www.eff.org/https-everywhere' && open 'https://addons.mozilla.org/en-US/firefox/addon/privacy-possum/versions' && open 'https://addons.mozilla.org/en-US/firefox/addon/cookie-autodelete/versions' && open 'https://addons.mozilla.org/en-US/firefox/addon/ublock-origin/versions'

uBlock Origin

Settings
Filter lists
Custom 3rd-party filters
https://www.fanboy.co.nz/fanboy-problematic-sites.txt
https://www.fanboy.co.nz/r/fanboy-ultimate.txt
https://www.fanboy.co.nz/fanboy-antifacebook.txt
https://www.fanboy.co.nz/fanboy-antifonts.txt
https://www.fanboy.co.nz/fanboy-cookiemonster.txt
https://raw.githubusercontent.com/ryanbr/fanboy-adblock/master/popads-domains-list.txt
https://raw.githubusercontent.com/ryanbr/fanboy-adblock/master/fake-news.txt

Testing Sites

SwitchResX

Transmission

http://john.bitsurge.net/public/biglist.p2p.gz
curl -sI http://john.bitsurge.net/public/biglist.p2p.gz | grep Last-Modified

VLC

WireGuard

VPN.AC

Diagnostics

Geekbench

GpuTest

Fur Ring

720p
~/'Downloads/GpuTest_OSX_x64_0/GpuTest.app/Contents/MacOS/GpuTest' /test='fur' /width='1280' /height='720' /benchmark /benchmark_duration_ms='10000'
1080p
~/'Downloads/GpuTest_OSX_x64_0/GpuTest.app/Contents/MacOS/GpuTest' /test='fur' /width='1920' /height='1080' /benchmark /benchmark_duration_ms='10000'
4K
~/'Downloads/GpuTest_OSX_x64_0/GpuTest.app/Contents/MacOS/GpuTest' /test='fur' /width='3840' /height='2160' /benchmark /benchmark_duration_ms='10000'

Benchmarks

/benchmark /benchmark_duration_ms='15000'
/fullscreen

Heaven Benchmark

Games

Battle.net

FINAL FANTASY XIV

Game Data

~/Library/Application Support/FINAL FANTASY XIV ONLINE/Bottles/published_Final_Fantasy/drive_c/Program Files (x86)/SquareEnix/FINAL FANTASY XIV - A Realm Reborn

Guild Wars 2

Old School RuneScape

Java

OpenArena

RuneScape

Steam

Xonotic

Settings

Safari

Settings

Terminal

3)
will continue to do so anyway until an issue arises :p
4)
if Gatekeeper blocks Firefox from starting normally anyway, run sudo spctl --master-disable, start Firefox, and run sudo spctl --master-enable immediately afterwards
5) , 6)
uncheck; included in Fanboy Ultimate List
7)
which will not install or run on Catalina/10.15 since it's currently 32-bit
8)
this fixes comment editing on egpu.io